Kate's Comment

Thoughts on British ICT, energy & environment, cloud computing and security from Memset's MD

Multi-screen work station – sharing keyboard & mouse between Macs

At my home office I’ve got three screens plus my Mac Air (see right). I’m driving the middle one as a secondary monitor for the ‘Air and the other two from a Mac Mini under the desk.

In a perfect world I would want to be able to drag things seamlessly between all four screens. I have been reliable informed (by my friend Jon Topper) that you can get a Mac to drive four screens with Display Link USB to DVI adapters but I just don’t think my poor little ‘Air would cope. Part of the rationale of getting the Mac Mini was to offload the ‘Air and get a competent games and video editing machine as part of the bargain.

Kayboard and mouse sharing tools for MacOS

So, instead I just wanted to be able to move the mouse / keyboard focus seamlessly between the screens. I tried Synergy but just could not get it to work. On my Mac Mini (OSX Lion) it crashes immediately.

Instead I tried Teleport. The earlier versions were quite unstable (I’ve been experimenting with this for a few months) and I ended up in a situation where although it had been working it was no longer.

Fixing Teleport

In the past the issues had been caused by Teleport getting its knickers in a twist over changed IP addresses or machine names (I lost/broken/upgraded my Mac Air several times in 2012) and found that generally the following steps in some combination would work:

  • Turn off Teleport in its preference pane on both machines
  • Quit System Preferences
  • Re-open system prefs
  • Re-activate Teleport

Sometimes I would need to swap around which had “Share this Mac” ticked (denotes the one being remotely controlled) to get it working.

This latest problem was a total failure though, which I suspect to be due to my having upgraded the machines since Teleport was originally installed. The Macs could see each others’ screens but they showed in the arranger in red. Much fiddling and rebooting did not help. Therefore I decided to completely reinstall Teleport, which is a little harder tha it first appears!

Uninstalling Teleport (or Synergy)

Note that these steps also work perfectly well for uninstalling Synergy KM – just change “teleport” to “synergy”.

To remove it you need to find the relevant files using the console and delete them, as well as killing off the process. You should be able to kill the process by unticking “Activate teleport” in its preference pane and to confirm that it is no longer running, type:

ps aux | grep teleport

If there is only one process showing (the grep) then you’re good. If not, use ‘kill’, as I have in this example:

KatAir-2:~ khcw$
KatAir-2:~ khcw$ ps aux | grep teleport
khcw 525 0.0 0.0 2432768 588 s001 S+ 2:20pm 0:00.00 grep teleport
khcw 520 0.0 0.2 2579184 20708 ?? S 2:19pm 0:00.43 /Library/PreferencePanes/teleport.prefPane/Contents/Resources/teleportd.app/Contents/MacOS/teleportd -psn_0_323663
KatAir-2:~ khcw$
KatAir-2:~ khcw$ kill 520
KatAir-2:~ khcw$

Now comes the tricky bit. You also need to remove all of Teleport’s files. You may just need to remove the preference pane and its .prefPane and .plist but I removed all its other files as well just to be sure. To find the files us mdfind from the console, thus:

KatAir-2:~ khcw$
KatAir-2:~ khcw$ mdfind -name teleport
/Users/khcw/Library/Preferences/com.abyssoft.teleport.plist
/Users/khcw/Library/Caches/com.abyssoft.teleport
/Library/PreferencePanes/teleport.prefPane
/Users/khcw/Downloads/teleport/teleport.prefPane
/Users/khcw/Downloads/teleport
/Users/khcw/Downloads/teleport.zip
KatAir-2:~ khcw$

Now I could give you some clever xargs + rm foo here to delete everything in one handy command but that would be rather dangerous (you might have other files called “Teleport”!) so use the following command and paste the file names onto the end:

sudo rm -rf <filename>

Using my example above you would run the following commands:

KatAir-2:~ khcw$ sudo rm -rf /Users/khcw/Library/Preferences/com.abyssoft.teleport.plist
Password:
KatAir-2:~ khcw$ sudo rm -rf /Users/khcw/Library/Caches/com.abyssoft.teleport
KatAir-2:~ khcw$ sudo rm -rf /Library/PreferencePanes/teleport.prefPane

You will be asked for your password since you are using sudo (switches you into superuser mode). Be very careful with “sudo rm -rf” – you can delete files which stop your computer working if not!

Now that Teleport has been removed, simply reinstall it and you should hopefully be good to go!

I just realised that you can actually just right-click on Teleport in System Preference and remove it that way. *facepalm* That may be all you need to do to uninstall it but I’ve not tried the easy way. :$

Performance

On Two Worlds II (one of my favourite games) there are very time-critical things like the lock pick mini game. I think there might have been a tiny perceptible delay but I am not certain – it seemed like I had to click a few miliseconds before where I would have before.

Therefore I switched it around so that the Mac Mini was the keyboard and mouse server since I don’t do anything latency sensitive on my ‘Air. This also has two other key advantages: First, I have one less wire to connect to my ‘Air when I plug into my home setup and secoond if there is an issue with Teleport (which there quite often is) I already have a keyboard and mouse connected to both machines (the ‘Air’s built-in ones).

security

I did not like the fact that it wants a connection to www.abyssoft.com (Little Snitch, my local firewall and network monitor, informed me). I allowed it at first but then blocked it – almost certainly just checking for updates but it was a free download and would be the perfect vehicle for a keylogger harvesting info and transmitting it back to a central source.

Personally I would not trust such a system over an untrusted network either. Yes, it has an encryption capability but I’d rather not rely on that.

No comments yet...